Klipper Screen Timezone Fix

Hi all,
I have the Sovol Klipper screen on my SV06+ and noticed that the timezone options in the settings were pretty limited in the ‘Americas’ category. Namely, I live in California and there was no option to select a city in the Pacific Timezone. I have seen mention of this issue from others as well, so rather than fixing this one off for myself and possibly fight the Klipper or Sovol code on reboots, I found the code for the Klipper configuration and changed the options to reflect the names of timezones rather than cities. It still applies a city name in the background because of how the OS works, but the options will show the timezone name and offset number for each.

Check out the code and instructions at my github repo

Feel free to create a GH issue if you find some edits that need to be made.