Cura won't connect to SV04

I just purchased an SV04 and I am able to print fine from the SD card.

I installed the latest version of Cura software from the support page on my windows PC, added the 5 printers for the SV04 (dual, mirror, copy, single 01, and single 02).

However, Cura is not seeing the printer.

My laptop is recognizing the device, as it is beeping when I plug it in and the SV04 screen is powered up even with the unit unplugged.

Anyone have any suggestions?

Do I need a driver for my Windows PC? I see USB-SERIAL CH340 (COM4) in my device manager.

I tried the FT232 driver from a similar post and when I updated it said I already had the latest.

I have tried 2 different USB data cables and 2 different Laptops - both times I connected directly to the laptop.

I tried the 1.3.0 Cura that came with the unit, as well as 1.5.7 from the support site.

Thanks in advance for any assistance.

Install Pronterface / Printrun on your laptop(s).
If you’re able to send gcode commands to your SV04 via Pronterface than you narrowed the problem down to Cura.

I installed ideaMaker 4.3.2 with the SV04 profile and I am still not able to connect as well.

The firmware on the printer I have is 1.1.4 which is newer than the firmware on the SOVOL support site.

Anyone have any other suggestions?

Where did you that firmware & how about trying to connect with Sovol’s current firmware version running on your SV04?

I just tried flashing the latest firmware from the SOVOL site, I followed the instructions exactly, and it won’t flash. I confirmed that the card I used was readable by copying the SD card that came with the unit onto it first and the printer saw the files there fine. I’m beginning to think I just have a defective unit.

Flashing problems caused by the SD-card is a common problem. Try to remove all files & folders, including the hidden ones from the SD-card besides “firmware.bin”. If it still does not flash, you’ll need to format the SD-card (FAT32, 4096 Bytes format) & try again.

Hi Bjoern - thanks for all of the assistance. I actually formatted the card first, then copied the firmware file over and inserted it into the printer, turned it on and it wouldn’t update - it just booted as if it didn’t see the firmware file. I then copied over the files from the original SD card that came with the printer, and the printer saw all the sample files, confirming that the SD card is fine.